boote-forum.de - Das Forum rund um Boote  

Zurück   > >

Kein Boot Hier kann man allgemeinen Small Talk halten. Es muß ja nicht immer um Boote gehen.

Antwort
Vorherige Seite - Ergebnis 1 bis 20 von 22
 
Themen-Optionen
  #21  
Alt 05.05.2004, 15:04
Benutzerbild von moskito
moskito moskito ist offline
Vice Admiral
 
Registriert seit: 18.11.2002
Ort: Provence
Beiträge: 1.411
6 Danke in 5 Beiträgen
Standard

Zitat:
Zitat von Bernd
Also da Fehlern 90% der brauchbaren Header. Kannst du mal zum Vergleich die e-Mail wo es ging auch noch dazu setzen. Bis jetzt sehe ich 100 Stellen die so nicht gehen
Bernd
ich habe keinen, wo es ging...leider.. habe in der Kopie nur die mail adressen rausgenommen, hast du wahrscheinlich schon bemerkt,oder
Mit Zitat antworten top
  #22  
Alt 05.05.2004, 15:25
Benutzerbild von Seestern
Seestern Seestern ist offline
Admiral
 
Registriert seit: 06.05.2002
Ort: MH a.d. Ruhr, Revier: Rhein
Beiträge: 3.862
Boot: Quicksilver Activ 535 Open + Mercury 100 EFI
Rufzeichen oder MMSI: DD5148 / 211540300
4.661 Danke in 2.032 Beiträgen
Standard

Das Problem setzt sich wahrscheinlich aus mehreren Komponenten zusammen.

TCIP/IP in erster Linie mal auf 7Bit-Zeichensätze und deren Übertragung ausgelegt worden. Umlaute finden (fanden?) also im Standard nicht statt. Nun gibt es Faktoren:

a) Maskieren
Jetzt kann man jedes Zeichen auch durch eine 7Bit-Zeichenkette darstellen: In URLs habt Ihr sicher schon mal "%20" gesehen, wo vorher ein Leerzeichen war? Oder im HTML-Quellcode ein ü statt eines "ü"? Wenn die verwendeten eMail-Programme Sonderzeichen also sauber maskieren und demaskieren, besteht kein Problem - der übertragene Text ist 7Bit. Das betrifft übrigens auch HTML-Mails, denn "sauberer" HTML-Quellcode enthält keine Sonderzeichen.
Also Problem 1: ich denke die wenigsten Programme inkl. Outlook konvertieren Sonderzeichen wirklich Standard-konform, vielleicht Mozilla (da OpenSource).

b) Mailserver
Wird nun eine eMail mit (unmaskierten) Sonderzeichen verschickt und auf dem Weg zwischen Sender und Empfänger sind nur sonderzeichen-fähige Mailserver, ist das auch kein Problem - alles funktioniert. Ist aber ein "7-Bit-Mailserver" (sprachlich etwas ungenau) darunter, interpretiert und transportiert der nur 7 Bit eines 8-Bit-Sonderzeichens. Deswegen werden i.d.R. Sonderzeichen (Umlaute, EUR) auch immer durch dasselbe kryptische Zeichen ersetzt.
Da weder Sender noch Empfänger abschließend Einfluss auf alle beteiligten Mailserver hat - bei den Providern können ja durchaus mehrere involviert sein - bleibt immer ein Restrisiko.

Ich verzichte auf Umlaute im Subject und auf das EUR-Zeichen und nehme in Kauf, dass Umlaute im Text in Einzelfällen nicht richtig maskiert werden.
__________________
Andreas
www.bootstechnik.de

alle Binnen-Pflichtdokumente elektronisch dabeihaben: Thread 178207
Ruhrskipper: http://www.bootstechnik.de/downloads/ruhrschleusen.pdf (Version: 11.07.2019)
Mit Zitat antworten top
Antwort
Vorherige Seite - Ergebnis 1 bis 20 von 22

Themen-Optionen

Forumregeln
Es ist Ihnen nicht erlaubt, neue Themen zu verfassen.
Es ist Ihnen nicht erlaubt, auf Beiträge zu antworten.
Es ist Ihnen nicht erlaubt, Anhänge hochzuladen.
Es ist Ihnen nicht erlaubt, Ihre Beiträge zu bearbeiten.

BB-Code ist an.
Smileys sind an.
[IMG] Code ist an.
HTML-Code ist aus.

Gehe zu


Alle Zeitangaben in WEZ +2. Es ist jetzt 12:16 Uhr.


Powered by vBulletin® Version 3.8.11 (Deutsch)
Copyright ©2000 - 2020, vBulletin Solutions, Inc.